低版本VS项目在VS2019无法正常编译的问题

    低版本VS项目在VS2019无法正常编译的问题

    这里指的编译并不准确,只是为了方便说明。

    今天新装了VS2019想换个新环境,打开原来项目的时候发现大量报错,而项目原本是没有问题的,想着是可能由于VS2019升级了编译器(对应版本:

    Microsoft.CodeDom.Providers.DotNetCompilerPlatform.2.0.0),上网查找后知道解决办法,记录在下。

    问题说明

    主要表现为:

    错误列表中大量 “无法打开源文件”错误资源列表中许多文件无法包含前两个问题导致的代码中问题(格式、类型声明、定义等)解决方法

    主要原因是开发平台工具集的缺失,VS2019不自动下载之前版本的工具集(安装时未主动选择的话)。

    1、找到所需工具集版本

    解决方案→项目属性→常规:平台工具集

    图片中为解决后的界面,实际情况应为列表中有VS 2019(v142)和VS 201?(v140),且VS 201?后有(未安装),201?指项目原本开发工具

    2、下载所需工具集

    工具→获取工具和功能→可用→单个组件:往下翻找到“编译器、生成工具和运行时”,在其中选择对应工具集

    比如我缺失的是VS 2015(v140)

    安装后,在之前属性界面即可选择对应工具集

    参考:https://www.wandouip.com/t5i207272/

    到此这篇关于低版本VS项目在VS2019无法正常编译的问题的文章就介绍到这了,更多相关VS2019无法正常编译低版本内容请搜索lingkb以前的文章或继续浏览下面的相关文章希望大家以后多多支持lingkb!