华为5700和ar2220s局域网部署 华为5700 ar2220s局域网配置及无法上网解决方法

    华为ar2220s系列路由器同时提供了基于Web的配置管理平台和经典命令行配置方式,其中的Web配置管理平台非常易于使用,可进一步降低中小型企业和大型企业分支机构对于专业IT人员的需求,并减少日常网络管理工作的负担。

    空闲时间将公司网络整理了下,网上把公司办公楼和车间的网络同步实现相互访问,算是把这几天的计划给完成

    接下来就来看看部署情况:

    wKioL1jNKOrDHlt-AAOFkruTu4s540.jpg

    wKioL1jNKOvS4CMLAAFlLcAvA0o829.jpg

    加红色命令为新添加上

    AR2220s路由器地址配置

    dns resolve

    dns server 202.102.224.68

    dns server 202.102.227.68 河南联通dns解析地址

    interface GigabitEthernet0/0/0 路由器端口地址,下面对应的路由下一跳为本地址

    tcp adjust-mss 1200

    ip address 192.168.1.1 255.255.255.0

    nat outbound 2998

    dhcp select interface

    dhcp server lease day 0 hour 1 minute 0

    dhcp server dns-list 192.168.1.1

    ip route-static 1.0.0.0 255.255.255.0 GigabitEthernet0/0/0 192.168.1.2

    ip route-static 10.0.0.0 255.255.0.0 GigabitEthernet0/0/0 192.168.1.2

    ip route-static 111.111.110.0 255.255.255.128 GigabitEthernet0/0/0 192.168.1.2

    ip route-static 192.168.77.0 255.255.255.0 GigabitEthernet0/0/0 192.168.1.2

    #s5700配置各个vlanif的虚拟地址段指向 vlanif1的虚拟ip地址

    个人理解因该是端口pvid检查,可以让通过vlanif ip地址通过本路由器

    vlan配置信息,是中间华为s5700配置

    端口

    interface GigabitEthernet0/0/1

    port link-type access

    #

    interface GigabitEthernet0/0/2

    port link-type access

    port default vlan 2

    #

    interface GigabitEthernet0/0/3

    port link-type access

    port default vlan 3

    #

    interface GigabitEthernet0/0/4

    port link-type access

    port default vlan 4

    #

    interface GigabitEthernet0/0/5

    port link-type access

    port default vlan 5

    #

    interface GigabitEthernet0/0/6

    port link-type access

    port default vlan 6

    虚拟端口

    interface Vlanif1

    description ar2220s

    ip address 192.168.1.2 255.255.255.0

    #

    interface Vlanif2

    ip address 10.0.0.1 255.255.255.252

    dhcp select interface

    #

    interface Vlanif3

    ip address 10.0.0.9 255.255.255.248

    dhcp select interface

    dhcp server dns-list 192.168.1.1

    #

    interface Vlanif4

    description office building

    ip address 111.111.110.1 255.255.255.128

    dhcp select interface

    dhcp server lease day 0 hour 1 minute 0

    dhcp server dns-list 192.168.1.1

    #

    interface Vlanif5

    ip address 1.0.0.1 255.255.255.0

    dhcp select interface

    dhcp server lease day 0 hour 1 minute 0

    dhcp server dns-list 192.168.1.1

    #

    interface Vlanif6

    ip address 192.168.77.1 255.255.255.0

    dhcp select interface

    dhcp server excluded-ip-address 192.168.77.100 192.168.77.200

    lease day 0 hour 1 minute 0

    dhcp server dns-list 192.168.1.1 配置dns段和dhcp租期、IP地址段

    端口

    interface GigabitEthernet0/0/1

    port link-type access

    #

    interface GigabitEthernet0/0/2

    port link-type access

    port default vlan 2

    #

    interface GigabitEthernet0/0/3

    port link-type access

    port default vlan 3

    #

    interface GigabitEthernet0/0/4

    port link-type access

    port default vlan 4

    #

    interface GigabitEthernet0/0/5

    port link-type access

    port default vlan 5

    #

    interface GigabitEthernet0/0/6

    port link-type access

    port default vlan 6

    个人理解:虚拟端口和对应vlan端口组成一个路由器

    ip route-static 0.0.0.0 0.0.0.0 192.168.1.1 配置静态路由 这个指向的是上级路由地址

    配置这次遇到两个问题:

    1:s5700连接ar2220 上外网问题

    原因:没有在ar2220上配置路由表静态地址 导致无法上外网

    ip route-static 1.0.0.0 255.255.255.0 GigabitEthernet0/0/0 192.168.1.2

    ip route-static 10.0.0.0 255.255.0.0 GigabitEthernet0/0/0 192.168.1.2

    ip route-static 111.111.110.0 255.255.255.128 GigabitEthernet0/0/0 192.168.1.2

    ip route-static 192.168.77.0 255.255.255.0 GigabitEthernet0/0/0 192.168.1.2

    和没有在5700上面配置静态地址

    ip route-static 0.0.0.0 0.0.0.0 192.168.1.1

    2:vlanif6配置和其他一样仍然无法上网,包括无法和192.168.1.1 ping 通

    原因:

    路由器ge 0/0/0 是192.168.1.1 ge 0/0/1是192.168.77.1

    而交换机5700 vlanif 6也是192.168.77.1 导致无法上网

    wKioL1jNLpHQWHkhAAJNasvJEB4465.jpg

    将ge 1口关闭了 问题解决

    这是 冲突原因 也是寻找问题的本质关键。

发表评论

发表评论